查看centos内核的版本

uname -a
uname -r

查看linux版本

cat /etc/issue

查看系统是64位还是32位

getconf LONG_BIT

安装node.js

因为node.js需要Python2.6以上

Note: Python 2.6 or 2.7 is required to build from source tarballs.

查看Python版本

python -V

安装依赖

yum -y install gcc make gcc-c++ openssl-devel wget

下载node.js源码及安装

wget http://nodejs.org/dist/v0.12.0/node-v0.12.0.tar.gz
tar -zxf node-v0.12.0.tar.gz
cd node-v0.12.0
./configure && make && make install